Message Boards

Back

Ace & Inspina trial setup fails

Toggle
Ace & Inspina trial setup fails
Answer
11/13/15 2:10 AM
Hi, 
I have tried installing Ace as well as Inspina as a trial version from the LR marketplace.
They do both show up on my site, but don't work: they don't have icons and when I apply them to any page of my site, I get raw text as output: it doesn't seem there is any CSS or any content whatsoever existing on my server. 
0 (0 Votes)

RE: Ace & Inspina trial setup fails
Answer
11/13/15 5:14 AM as a reply to Khaoula.
Hi,

no, I can't:
I have "de-installed" both. Now in the "purchased Apps" list I do see both products with the "Install" button.
Pressing one brings me to the "License"-page (Please select a license to continue with the installation).
There the radio-button for the trial license is grayed out. So I can't license.

Strange enough, even though I have de-installed both, "Ace" is still available for use in the template selector ("look-and-feel"-settings)
"Inspina" however is gone as you would expect.

Where can I find the respective logs? 
I checked the apache-logs for apparent directory privilege violations but couldn't find any.

EDIT: I found these: 
12345
11:49:44,323 INFO  [localhost-startStop-3][HotDeployImpl:273] Queueing inspinia-theme for deploy because it is missing resources-importer-web

[blablabla - dependency has been resolved then theme installation runs through.]

11:49:49,633 INFO  [localhost-startStop-3][ThemeHotDeployListener:113] 1 theme for inspinia-theme is available for use
Even though it's strange that apparently there have been missing dependencies at the install of the _SECOND_ theme (I installed Ace prior to this), they seem to have been resolved properly; there's no errors to be found here.

The only strange message is (after un-deploying): 
1
Plugin package on context inspinia-theme cannot be tracked because this WAR does not contain a liferay-plugin-package.xml file
0 (0 Votes)

RE: Ace & Inspina trial setup fails
Answer
11/13/15 5:09 AM as a reply to Jan Lausch.
Hi Jan, 
Did you purchased any of them? If yes then we can give you access to the corresponding themes ressources in themeray.com This way you will not have licensing problems.
Regards
Adel
0 (0 Votes)

RE: Ace & Inspina trial setup fails
Answer
11/13/15 5:13 AM as a reply to Adel Frad.
Hi,

I "purchased" the free trial license for both - in the LR-App store.

I didn't purchase any paid license at all in Liferay yet as we're just starting to try it out here. 
0 (0 Votes)

RE: Ace & Inspina trial setup fails
Answer
11/13/15 5:15 AM as a reply to Jan Lausch.
The first log output looks ok. The second looks strange. Please install the theme in a different liferay insrance and tell us what you get.
Regards
0 (0 Votes)

RE: Ace & Inspina trial setup fails
Answer
11/13/15 6:09 AM as a reply to Adel Frad.
I have only one installation - we're just evaluating LR. And this installation is just 2 days old on a freshly set up machine.

Also I just tried with a different Theme from another vendor (also a trial version) and have even more problems even though again the logs show no errors - which is a bit diusturbing (It's installed but not visible in the theme selector at all).

But whatever - I will just go on evaluating LRs with the default template to decide on a CMS - if we decide to go with LR, then it is soon enough to start figuring out these problems.

Thanks anyway!
0 (0 Votes)

RE: Ace & Inspina trial setup fails
Answer
11/13/15 6:34 AM as a reply to Jan Lausch.
You are welcome.
If needed our guys could organize a teamviewer session and try to help you.
Regards
0 (0 Votes)

RE: Ace & Inspina trial setup fails
Answer
11/25/15 3:06 AM as a reply to Adel Frad.
Hi there,

ok, I am officially lost now.
In order to find a way to use your theme, I have tried liferay installations on several platforms:

- a firely hosted liferay
- a Bitnami VM on AWS
- a Bitnami VM on google 
- a local VM with ubuntu / liferay.

The first one didn't even allow installation because liferay didn`t detect the VMs MAC address. But that aside, each and every of these machines where pre-configured images where I did do absolutely NOTHING after initialisation but just to log in to the store and download a trial of Inspina or Ace. 
In ALL of these cases the result always was that the theme installed fine (log shows successfull deployment) but in the theme overview all Icons of the theme are missing and if I activate it, the frontpage is completely CSS-less, just raw text.

Please help. I have to start with a project and as we will require a dashboard-theme there's not too many options on how to go and your theme looks great - but something am I missing. 
Is it perhaps that the file permissions have to be adjusted? 

I am open for a Teamviewer session or any other help I can get.

0 (0 Votes)

RE: Ace & Inspina trial setup fails
Answer
11/25/15 3:15 AM as a reply to Jan Lausch.
log output:

/opt/bitnami/apps/liferay/data/logs/liferay.2015-11-25.log



13:41:04,438 INFO [localhost-startStop-2][HotDeployImpl:217] Deploying inspinia-theme from queue
13:41:04,438 INFO [localhost-startStop-2][PluginPackageUtil:1016] Reading plugin package for inspinia-theme
13:41:04,648 INFO [localhost-startStop-2][ThemeHotDeployListener:98] Registering themes for inspinia-theme
13:41:06,416 INFO [localhost-startStop-2][ThemeHotDeployListener:113] 1 theme for inspinia-theme is available for use
13:41:29,384 INFO [liferay/hot_deploy-1][ResourcesImporterHotDeployMessageListener:129] Importing resources from inspinia-theme to group 20746 takes 22707 ms

------------------- 
I tried to undeploy 


14:09:50,067 INFO [ajp-apr-8009-exec-16][DeployUtil:209] Undeploy /opt/bitnami/apache-tomcat/webapps/inspinia-theme
14:09:50,124 INFO [ajp-apr-8009-exec-16][DeployUtil:234] Wait 0 ms to allow the plugin time to fully undeploy
14:09:50,135 INFO [ajp-apr-8009-exec-16][DeployUtil:209] Undeploy /opt/bitnami/apache-tomcat/webapps/resources-importer-web
14:09:50,163 INFO [ajp-apr-8009-exec-16][DeployUtil:234] Wait 0 ms to allow the plugin time to fully undeploy
14:09:57,195 INFO [ContainerBackgroundProcessor[StandardEngine]][HotDeployEvent:145] Plugin inspinia-theme requires marketplace-portlet
14:09:57,196 INFO [ContainerBackgroundProcessor[StandardEngine]][ThemeHotDeployListener:140] Unregistering themes for inspinia-theme
14:09:57,201 INFO [ContainerBackgroundProcessor[StandardEngine]][ThemeHotDeployListener:172] 1 theme for inspinia-theme was unregistered
14:09:57,203 INFO [ContainerBackgroundProcessor[StandardEngine]][PluginPackageUtil:1016] Reading plugin package for inspinia-theme
14:09:57,203 WARN [ContainerBackgroundProcessor[StandardEngine]][PluginPackageUtil:1114] Plugin package on context inspinia-theme cannot be tracked because this WAR
does not contain a liferay-plugin-package.xml file
14:09:57,729 INFO [ContainerBackgroundProcessor[StandardEngine]][HotDeployEvent:145] Plugin resources-importer-web requires marketplace-portlet
14:09:57,730 INFO [ContainerBackgroundProcessor[StandardEngine]][HookHotDeployListener:952] Hook for resources-importer-web was unregistered
14:09:57,732 INFO [ContainerBackgroundProcessor[StandardEngine]][PluginPackageUtil:1016] Reading plugin package for resources-importer-web



Re-Deploy:
Not possible because apparently the license didn't get deleted during undeployment - so I can't install it a second time because there's no license available (even though it is still listed in license management).
Great. Same with Ace, there my trial license is stuck in another VM where I never managed to get it deleted from.

Shall I create a new store-login for a new trial or what?
0 (0 Votes)

RE: Ace & Inspina trial setup fails
Answer
11/25/15 3:21 AM as a reply to Jan Lausch.
Hi Jan, 
it looks like the theme was setup and ressources were imported properly. Could you try an another theme please? Also (a free) one from www.themeray.com ? It may be a licensing issue from Liferay Marketplace. From the screensho, it looks like you have an issue accessing the ressources in the file system. Are you using a migrated Liferay instance (6.1 -> 6.2) ?
Regards.
0 (0 Votes)

RE: Ace & Inspina trial setup fails
Answer
11/25/15 3:59 AM as a reply to Adel Frad.
Hi, 

thanks for the quick reply.

No, no updates, no migrations, it's a freshly set up Bitnami image. I even just set up another fresh one - this is on a freshly setup machine: 
Liferay Portal Community Edition 6.2 CE GA4 (Newton / Build 6203 / April 16, 2015)

Ok, installing Beveled from WAR-file:

14:50:57,549 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][AutoDeployDir:204] Processing beveled-theme-6.2.0.1.war
14:50:57,552 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][ThemeAutoDeployListener:51] Copying themes for /opt/bitnami/apps/liferay/data/deploy/beveled-theme-6.2.0.1.war
14:50:57,560 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][BaseDeployer:863] Deploying beveled-theme-6.2.0.1.war
14:50:57,964 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][BaseDeployer:2391] Modifying Servlet 2.4 /opt/bitnami/apache-tomcat/temp/20151125145057563/WEB-INF/web.xml
14:50:58,427 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][ThemeAutoDeployListener:57] Themes for /opt/bitnami/apps/liferay/data/deploy/beveled-theme-6.2.0.1.war copied successfully
. Deployment will start in a few seconds.
14:51:07,265 INFO [localhost-startStop-2][HotDeployEvent:145] Plugin beveled-theme requires marketplace-portlet, resources-importer-web, web-form-portlet
14:51:07,265 INFO [localhost-startStop-2][HotDeployImpl:217] Deploying beveled-theme from queue
14:51:07,266 INFO [localhost-startStop-2][PluginPackageUtil:1016] Reading plugin package for beveled-theme
14:51:07,458 INFO [localhost-startStop-2][ThemeHotDeployListener:98] Registering themes for beveled-theme
14:51:09,167 INFO [localhost-startStop-2][ThemeHotDeployListener:113] 1 theme for beveled-theme is available for use
14:51:15,050 INFO [liferay/hot_deploy-1][ResourcesImporterHotDeployMessageListener:129] Importing resources from beveled-theme to group 20734 takes 5630 ms


--> no warnings here.
Result: the same. Not working.

Ok, looking at file permissions:




Are these what they are supposed to be? 
owner = tomcat looks fine, the permissions alos look fine.
??
0 (0 Votes)

RE: Ace & Inspina trial setup fails
Answer
11/25/15 4:03 AM as a reply to Jan Lausch.
Yes, please check the permission in tomcats work and temp folder. Also "ps -ef" and check with which user you started the tomcat process. 
Did you tried beveled from themeray or from marketplace? 
0 (0 Votes)

RE: Ace & Inspina trial setup fails
Answer
11/25/15 4:17 AM as a reply to Adel Frad.
Dear Adel,

beveled was installed from themeray -> local upload of the WAR.
So a different way than ACE / Inspinia, but the same result.

root@bitnami-liferay-8ee0:~# ls -la /opt/bitnami/apache-tomcat/work
total 12
drwxr-xr-x 3 tomcat tomcat 4096 Nov 16 13:18 .
drwxr-xr-x 10 root root 4096 Nov 16 13:16 ..
drwxr-xr-x 3 tomcat tomcat 4096 Nov 16 13:18 Catalina


In
/opt/bitnami/apache-tomcat/work/Catalina/localhost/

I do find as expected the folders
/opt/bitnami/apache-tomcat/work/Catalina/localhost/beveled-theme
/opt/bitnami/apache-tomcat/work/Catalina/localhost/welcome-theme (the standard theme, wich does work)
both as well as their subfolders and content have exactly the same owner and privileges.

Also in
/opt/bitnami/apache-tomcat/webapps/
I do find as expected as well the beveled-theme folder and the standard welcome-theme folder.
Both as well as their contents have exactly the same owner & privileges.

Given that all is equal regarding privileges, I don't see anything wrong here...?!


ps -ef shows:
 
tomcat 4280 1 19 14:45 ? 00:05:09 /opt/bitnami/java/bin/java -Djava.util.logging.config.file=/opt/bitnami/apache-tomcat/conf/logging.properties -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Xms2048M -Xmx4096M -Djava.awt.headless=true -XX:+UseG1GC -Dfile.encoding=UTF8 -Duser.timez
one=GMT -Djava.endorsed.dirs=/opt/bitnami/apache-tomcat/endorsed -classpath /opt/bitnami/apache-tomcat/bin/bootstrap.jar:/opt/bitnami/apache-tomcat/bin/tomcat-juli.jar -Dcatalina.base=/opt/bitnami/apache-tomcat -Dcatalina.home=/opt/bitnami/apache-tomcat -Djava.io.tmpdir=/opt/bitnami/apache-tomcat/temp org.apache.c
atalina.startup.Bootstrap start
0 (0 Votes)

RE: Ace & Inspina trial setup fails
Answer
11/25/15 4:26 AM as a reply to Jan Lausch.
Ok sent you an email. Our Guys will contact you to plan a teamviewer session. 
Regards. 
0 (0 Votes)

RE: Ace & Inspina trial setup fails
Answer
11/25/15 11:22 AM as a reply to Adel Frad.
Dear all,

I figured it out! My problem was: all my test-servers (except the firelay, which didn't work for another reason) where based on a Bitnami-image (self-hosted VM or cloud-based). The problem is: Bitnami has the initial setting to have the liferay not available at http://domain.com/, but at http://domain.com/liferay/

I noticed when I found this
/beveled-theme/images/common/openid.gif HTTP/1.1" 404 236
/liferay/documents/20182/0/welcome_cube/[....] HTTP/1.1" 200 452

in one of the apache logs 
/opt/bitnami/apache2/logs/access_log
/opt/bitnami/apache-tomcat/logs/localhost_access_log..txt

So to solve this problem, there are some Bitnami-tools to be used (manual intervention not advised):

If you haven't already:
0) get a fixed IP if required / not present (in case of AWS hosting or the like)
0.1) adjust DNS settings
0.2) Assign the desired domain to your server / instance
see:  https://wiki.bitnami.com/Google_Cloud_Platform/Servers#How_to_configure_a_custom_domain
cd /opt/bitnami/apps/liferay
sudo ./bnconfig --machine_hostname my-shop.com

1) Change the Tomcat settings to use / instead of /liferay/
see:  https://community.bitnami.com/t/how-can-change-the-default-url-to-access-my-application/3
sudo /opt/bitnami/apps/wordpress/updateip --appurl /

2) Adapt apache-config to allow the theme data to be found:
sudo vim /opt/bitnami/apps/liferay/conf/httpd-app.conf
Add for each theme to be used:

<Location /ace-theme>
ProxyPass ajp://localhost:8009/ace-theme
</Location>

3) And in the end restart: 
/opt/bitnami/ctlscript.sh restart

This is working for both: manually uploaded themes as well as those purchased in the liferay-store.
For all Bitnami-Users, I hope this helps.
0 (0 Votes)